Форум администраторов Windows

Клиентские системы Microsoft => Windows 7 => Тема начата: ALVLL от 17 Январь 2013, 20:28:31

Название: AHCI в WINDOWS 7
Отправлено: ALVLL от 17 Январь 2013, 20:28:31
Недавно установил SSD OCZ Vertex4 128(чисто под систему)
Всё работает нормально, грузится быстро, ошибок нет.
Протестировал Hard Disk Sentinel 4.10 PRO, выдаёт -
функция TRIM поддерживается SSD, но отключена.
Диск работает на 80%.
Проверил через behavior - DisableDeleteNotifi = 0 (т.е.TRIM включен)
В диспетчере устройств отсутствует контроллер AHCI.
В БИОСе AHCI включен.
В реестре msahci = 0
Диспетчер показывает -
IDE ATA/ATAPI контроллеры:
AMD SATA Controller
ATA Channel 0
ATA Channel 1
Стандартный двухканальный контроллер PCI IDE.
Драйверы переустанавливал.
Попробовал установщик MicrosoftFixit50470 - безполезно.

Win7 Ult x64 SP1 2012г плюс обновления
Mb Asus M4A87TD
OCZ-VERTEX4 SATA
ST350041 3AS SATA
ASUS DRW-24B3ST SATA
Название: Re: AHCI в WINDOWS 7
Отправлено: itpro от 17 Январь 2013, 21:32:07
Со статьей Как включить AHCI в Win 7 (http://winitpro.ru/index.php/2011/10/31/kak-vklyuchit-podderzhku-ahci-v-windows-7/), я так понимаю знакомились?
Драйвера чипсета и все качали с сайта производителя? версии последние?
Сделайте скриншот диспетчера устройств с развернутыми ветками IDE/Ata controller и Storage Controler и приложите его к посту.
Название: Re: AHCI в WINDOWS 7
Отправлено: tisi от 19 Январь 2013, 06:29:23
ещё не дочитав проблему до середины, я уже понял, что материнка асус ! в общем - я не помню точно всех плясок с бубном, ибо давненько было, а сейчас винду только поставил и из-за праздников всё некогда настроить..... . если вы не разберётесь и я не забуду, то потом вспомню..... и отпишу.
там долбаная проблема, которую можно решить 3 способами и какой именно мне прокатил, я не помню. копайте в сторону - удаление иде, установка стандартного мелкософтового драйвера и рейд драйвера (всё комплексно) . положительный результат, можно заметить не напрягаясь, просто через оценку виндой жесткого диска.
Название: Re: AHCI в WINDOWS 7
Отправлено: ALVLL от 20 Январь 2013, 18:20:33
Драйверы ставились в пакете.
http://i54.fastpic.ru/big/2013/0120/b9/d183b10163617209b27515ea800127b9.png
http://i52.fastpic.ru/big/2013/0120/96/1733083b05d5fef716f244e5bd5a6196.jpg
Название: Re: AHCI в WINDOWS 7
Отправлено: ALVLL от 21 Январь 2013, 19:53:29
Вобщем нашёл я причину, драйвер контроллера AHCI есть, но остановлен, требуется запуск.
Как запустить и не будет ли конфликта?
http://i52.fastpic.ru/big/2013/0121/ba/dfac840402becf34a437f8b77caf0dba.jpg
Название: Re: AHCI в WINDOWS 7
Отправлено: ALVLL от 22 Январь 2013, 06:03:51
Состояние драйвера контроллера AHCI в реестре:
http://i51.fastpic.ru/big/2013/0122/1e/8f93018943c304ec15e99b36cafd911e.jpg
То ли он не включается при загрузке, то ли его чтото выключает-?
А может надо RAID драйверы ставить-???
Название: Re: AHCI в WINDOWS 7
Отправлено: dimokkk от 22 Январь 2013, 09:08:19
Служб стартует сама, если в ней есть необходимость. Не стоит менять параметры запуска.
А в BIOS поддержка AHCI точно включена?
Название: Re: AHCI в WINDOWS 7
Отправлено: Sterh от 22 Январь 2013, 09:14:36
А может надо RAID драйверы ставить-???

У меня в BIOS-е есть 2 режима работы: IDE или RAID, но именно AHCI отдельно нет.  Как оказалось, чтобы работал AHCI  надо выбрать именно  RAID. В документации материнки указано: RAID mode includes AHCI
Название: Re: AHCI в WINDOWS 7
Отправлено: ALVLL от 22 Январь 2013, 15:26:12
Включение AHCI в БИОС :
http://i51.fastpic.ru/big/2013/0122/21/6cb7fe2fff4e6e04aca0e9d2e444a621.jpg
При включении режима RAID пропадают диски, система просит загрузочный девайс.
Название: Re: AHCI в WINDOWS 7
Отправлено: Sterh от 23 Январь 2013, 07:28:13
Включение AHCI в БИОС :
http://i51.fastpic.ru/big/2013/0122/21/6cb7fe2fff4e6e04aca0e9d2e444a621.jpg
При включении режима RAID пропадают диски, система просит загрузочный девайс.
Ну да, в этом случае нужно выбирать AHCI без вариантов...
А что, если попробовать включить TRIM ручками? Возможно это просто особенности названия драйвера и в его имени просто ничего не пишетмся про AHCI
fsutil behavior set DisableDeleteNotify 0
Название: Re: AHCI в WINDOWS 7
Отправлено: ALVLL от 23 Январь 2013, 08:56:00
Самое интересное,что тесты показывают что TRIM работает,NCQ поддерживается,а по идее без режима AHCI работать
не должны.Правда NCQ проверить невозможно,только на двух идентичных машинах,одна под AHCI другая под IDE.(по производительности)
Но всёже главное чтобы TRIM чистил SSD диск.
http://i53.fastpic.ru/big/2013/0123/c7/4603ab012725b51ed87961f0871ce2c7.jpg
http://i51.fastpic.ru/big/2013/0123/93/7f232d52b08608d208aa2ba3045d1793.jpg
(А контроллера AHCI так и нет.) 
Название: Re: AHCI в WINDOWS 7
Отправлено: Sterh от 23 Январь 2013, 09:27:38
Видимо  все-таки проблема в том, что ASUS просто ничего не указал про AHCI в названии драйвера контролера, и на самом деле режим работает, так что не парьтесь   :)
Название: Re: AHCI в WINDOWS 7
Отправлено: ALVLL от 27 Январь 2013, 23:42:06
В общем AHCI включен, всё работает нормально. Просто в диспетчере не прописан
режим контроллера SATA(IDE/AHCI).
http://i54.fastpic.ru/big/2013/0127/20/8e562125faa6a4a48e944ce65f9ea620.png
http://i53.fastpic.ru/big/2013/0127/13/5a8124b339b26acc89e82b5fc6243413.png
http://i54.fastpic.ru/big/2013/0127/25/b956b7be211613b426790caae8045325.png
http://i54.fastpic.ru/big/2013/0127/7b/d9e2c82e930858cc4da8bc3885df617b.png
Зря ломали голову, а может нет, кому нибудь пригодится.
Всем спасибо.